`
jishublog
  • 浏览: 861809 次
文章分类
社区版块
存档分类
最新评论

UVa 575 - Skew Binary

 
阅读更多

UVa 575 - Skew Binary

Table of Contents

1题目

===================

Skew Binary

When a number is expressed in decimal, thek-th digit represents a multiple of 10k. (Digits are numbered from right to left, where the least significant digit is number 0.) For example,

\begin{displaymath}81307_{10} = 8 \times 10^4 + 1 \times 10^3 + 3 \times 10^2 + ......mes 10^1 +7 \times 10 0 = 80000 + 1000 + 300 + 0 + 7= 81307.\end{displaymath}

When a number is expressed in binary, thek-th digit represents a multiple of 2k. For example,

\begin{displaymath}10011_2 = 1 \times 2^4 + 0 \times 2^3 + 0 \times 2^2 + 1 \times 2^1 +1 \times 2^0 = 16 + 0 + 0 + 2 + 1 = 19.\end{displaymath}

Inskew binary, thek-th digit represents a multiple of2k+1- 1. The only possible digits are 0 and 1, except that the least-significant nonzero digit can be a 2. For example,

\begin{displaymath}10120_{skew} = 1 \times (2^5 - 1) + 0 \times (2^4-1) + 1 \tim......2 \times (2^2-1) + 0 \times (2^1-1)= 31 + 0 + 7 + 6 + 0 = 44.\end{displaymath}

The first 10 numbers in skew binary are 0, 1, 2, 10, 11, 12, 20, 100, 101, and 102. (Skew binary is useful in some applications because it is possible to add 1 with at most one carry. However, this has nothing to do with the current problem.)

Input

The input file contains one or more lines, each of which contains an integern. Ifn= 0 it signals the end of the input, and otherwisenis a nonnegative integer in skew binary.

Output

For each number, output the decimal equivalent. The decimal value ofnwill be at most231- 1 = 2147483647.

Sample Input

10120
200000000000000000000000000000
10
1000000000000000000000000000000
11
100
11111000001110000101101102000
0

Sample Output

44
2147483646
3
2147483647
4
7
1041110737



Miguel A. Revilla
1998-03-10

===================

2思路

题目关键是结果不会超出整形所表示的范围,所以不用按大数运算处理,另外输入可以用字符串表示

3代码

/*
 * Problem: UVa 575 - Skew Binary
 * Lang: ANSI C
 * Time: 0.015
 * Author: minix
 */

#include <stdio.h>
#include <string.h>

#define N 32+5
int base[N];
char input[N];

int main() {
  int i, j;
  int por, len;
  double sum;

  por = 2;
  for (i=1; i<=31; i++) {
    base[i] = por -1;
    por *= 2;
  }

  while (scanf ("%s", input) != EOF) {
    if (!strcmp(input,"0")) break;
    len = strlen (input);
    j = 1; sum = 0;
    for (i=len-1; i>=0; i--)
      sum += base[j++] * (input[i]-'0');
    printf ("%.0lf\n", sum);
  }

  return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics