`
jishublog
  • 浏览: 862073 次
文章分类
社区版块
存档分类
最新评论

UVa 442 - Matrix Chain Multiplication

 
阅读更多

UVa 442 - Matrix Chain Multiplication

Table of Contents

1题目

===================

Matrix Chain Multiplication

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integern(tex2html_wrap_inline28), representing the number of matrices in the first part. The nextnlines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

===================

2思路

使用栈进行矩阵链乘计算,每一步的计算结果再入栈,直到没有矩阵参与运算。

3代码

/*
 * Problem: 442 - Matrix Chain Multiplication
 * Lang: ANSI C
 * Time: 0.012s
 * Author: minix
 */

#include <stdio.h>
#include <string.h>
#include <ctype.h>
#define N 26+5
#define M 1000
char line[M];
int row[N], col[N], top;
int stack_row[M], stack_col[M];

int main () {
  int n, i, sum;
  int cr, cc;
  char c;
  scanf ("%d", &n); getchar();
  for (i=0; i<n; i++) { 
    scanf ("%c %d %d", &c, &cr, &cc);
    row[c-'A'] = cr; col[c-'A'] = cc;
    getchar();
  }
  while(fgets (line, sizeof(line[0])*M, stdin)) {
    if (line[1]=='\n') {printf ("0\n"); continue;}
    i = 0; top = -1; sum = 0;
    while (line[i] != '\n') {
      if (line[i] == '(') { 
        top++; 
        stack_row[top] = stack_col[top] = line[i]; 
      }
      else if(isalpha(line[i])) {
        top++; 
        stack_row[top] = row[line[i]-'A']; 
        stack_col[top] = col[line[i]-'A'];
      } 
      else if (line[i] == ')') {
        if (stack_col[top-1] != stack_row[top]) { 
          printf ("error\n");break;
        }
        else {
          stack_row[top-2] = stack_row[top-1]; 
          stack_col[top-2] = stack_col[top];
          sum += stack_row[top-1]*stack_col[top-1]*stack_col[top];
          top -= 2;
        }
      }
      i++;
    }
    if (line[i]=='\n') printf ("%d\n", sum);
  }

  return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics